rsyslog

The rocket-fast system for log processing

rsyslog error 2222

Legacy parameter no longer permitted.

There is a conflict between a v6+ style module parameter and a legacy parameter. Once module-global parameters have been set in a module() statement, they can no longer be changed via legacy parameters. Note that this applies to all parameters, no matter if they are explicitly specified in the module() statement or not. Legacy parameters are blocked in order to prevent inconsitent results.

If you absolutely need to use the legacy parameters, you can still use $ModLoad instead of module(). Note, however, that this may result in inconsistent result, as it was always the case in the legacy system.

To solve the problem: The accompanying error message lists the legacy statement in question. Please check the module documentation to the equivalent v6+ parameter.